Eden Bass head service

An audio community like no other.

Moderators: rick, Mark Bassett

Eden Bass head service

Postby tunetown » Mon Jul 23, 2018 1:35 pm

T'Rockers,

I have recently acquired an Eden WT800 Bass head from 1998. It's the "A" version. It has an overheating issue when pushed, as I found out last night. A google search shows this is not uncommon in this version.

Can anyone point me in the direction of a competent service technician in Sydney who know's these amps and can get it playing as it should.

Cheers
User avatar
tunetown
Frequent Contributor
Frequent Contributor
 
Posts: 925
Joined: Fri Jan 25, 2008 9:33 am
Location: Sydney

Re: Eden Bass head service

Postby Paul Maybury » Thu Jul 26, 2018 11:18 am

Hi Peter, maybe it's too obvious to mention, but have you cleaned out the fan and heatsinks?
Paul
Paul Maybury
Frequent Contributor
Frequent Contributor
 
Posts: 690
Joined: Tue Nov 17, 2009 3:07 pm
Location: Melbourne

Re: Eden Bass head service

Postby tunetown » Thu Jul 26, 2018 12:18 pm

Paul Maybury wrote:Hi Peter, maybe it's too obvious to mention, but have you cleaned out the fan and heatsinks?
Paul

Not yet. I'll look into it over the coming weekend. The bloke I bought it from said it had been recently serviced.

Cheers
User avatar
tunetown
Frequent Contributor
Frequent Contributor
 
Posts: 925
Joined: Fri Jan 25, 2008 9:33 am
Location: Sydney


Return to The Turtlerock Forum

Who is online

Users browsing this forum: No registered users and 2 guests


cron